SKSE - Skyrim Script Extender

Dieses Thema im Forum "[Skyrim] Modveröffentlichungen" wurde erstellt von Suzie Q, 23. November 2011.

  1. Suzie Q

    Suzie Q Moderatorin Mitarbeiter

    Name: SKSE - Skyrim Script Extender
    Autor: ianpatt, behippo und scruggsywuggsy the ferret
    Benötigt: Skyrim
    Mod-Version: 1.04.07
    Größe: 198 kB
    Download: skse.silverlock.org

    Es ist vollbracht, noch bevor das Creation Kit erschienen ist, gibt es die erste Version von SKSE. :)

    Der einzige Wermutstropfen ist, dass wir wohl kein neues Thieves Arsenal bekommen werden, da scruggsywuggsy the ferret bestimmt weiterhin all seine Zeit für OBSE und SKSE benötigt. :cry:

    Die neue Version funktioniert nur mit dem Skyrim Beta Patch 1.4.7 (compatible with 1.4.20.0)
     
    Zuletzt bearbeitet: 28. Januar 2012
    Fern Gally, Hadrian, NordLady und 24 anderen gefällt das.
  2. Werbung (Nur für Gäste)
  3. theSoXX

    theSoXX Ehrbarer Bürger

    Wie krass ist das denn? Erstaunlich, dass die überhaupt rausfinden konnten, dass der ObScript dem von Skyrim beinahe gleicht. Respekt!
     
  4. Killfetzer

    Killfetzer Super-Moderator Mitarbeiter

    Irgendwie erinnere ich mich plötzlich an eine Aussage zur Creation Engine (frei formuliert):

    "Die Scriptsprache ist komplett neu gestaltet. Für Oblivion-Modder dürfte es erstmal schwierig werden sich dort einzufinden."

    Und jetzt soll ein Tool aus Oblivion mehr oder weniger unverändert in Skyrim funktionieren? Also noch eine Aussage, die wir als "stimmt so nicht wirklich" abhaken können...
     
    theSoXX gefällt das.
  5. theSoXX

    theSoXX Ehrbarer Bürger

    Ich würde eher behaupten, dass man die Funktionsfähigkeit dieser frühen Version des SKSE nicht zu 100% gewährleisten kann. Mit welchen Script-Mods denn bitte? Abwarten.
     
  6. Dante2000

    Dante2000 Hausvetter

    Ihr müsst beachten das jene Entwickler nahe mit Bethesda zusammenarbeiten. Sie müssen eine Art "Qualitätskontrolle" durchlaufen, bevor Bethesda ihr OK gibt. Demzufolge hat das Entwicklerteam auch spezielle Zugriffe durch Bethesda auf Spielinterne Vorgänge.
     
  7. Iceflame

    Iceflame Abenteurer

    Ich frage mich ja, wie sinnvoll es ist, einen Script Extender für ein noch nicht erschienenes Tool freizugeben.
     
  8. wedg64

    wedg64 Gebannter Benutzer

    Ist doch okay...
    dann muss niemand warten wenn das CK draußen ist
    und einer erfolgreichen Mdifikation staht nichts mher im wege!
    NifSkope hat auch schon ne neue .xml spendiert bekommen!
    Mit langsamen schritten schreitet es voran.^^
    Da verlier ich nicht das interesse. :D
     
    Zuletzt bearbeitet: 24. November 2011
  9. PlanB

    PlanB Ehrbarer Bürger

    Wieso warten? Es gibt bereits eine Mod für den Script Extender. ;)

    Skyrim -Elys- Uncapper

    Kennt man ja schon aus Oblivion.
    Ist zwar noch eine experimentelle Version, aber immerhin..
     
    Schmelz gefällt das.
  10. Schmelz

    Schmelz Vertrauter

    Erstmal danke für's vorstellen Suzie Q!

    Gibt es irgendwo genauere Informationen, was umgessetzt ist? (oder ist es soweit mit der letzten Version von OBSE identisch?)
    Wie ähnlich müssen sich die Scriptsprachen eigentlich sein? (etwa identisch, mit einigen mehr die die Bethesda-Mitarbeiter im laufen der Zeit gebraucht haben?)

    @PlanB: Danke! War mir bei Oblivion eine der wichtigsten Mods. Hoffentlich halte ich es doch durch, ohne Mods durchzuspielen. (Das hier macht es zu einer Herausforderung!)
     
  11. Der Readme ist zu entnehmen, dass SKSE momentan anscheinend nur eine Basis zum Laden von SKSE-Plugins (z.B. Elys Uncapper) ist. Inwiefern bereits Skript-Funktionen theoretisch nutzbar sind, ist nicht näher definiert. Aber nachdem laut Readme ja der Script-Code ziemlich ähnlich (oder fast gleich; Auslegungssache) ist, dürfte man ziemlich schnell SKSE-Funktionen nutzen können, wenn das CK da ist.

    Ähneln müssen sich die Sprachen überhaupt nicht. Aber je höher die Ähnlichkeit, desto einfacher kann man natürlich OBSE-Plugins (die dll-Dateien) und -Funktionen portieren. Wenn man allerdings mal die "neue" Engine als Beispiel nimmt, kannst Du davon ausgehen, dass es so ist, wie Du selbst schriebst, Schmelz. Es wurde vermutlich die alte Script-Engine genommen und mehr oder weniger komplex modifiziert (laut SKSE-Readme eher weniger :lol:) und das wird nun als neu verkauft.
     
  12. PlanB

    PlanB Ehrbarer Bürger

    theSoXX und Eldarie gefällt das.
  13. Eldarie

    Eldarie Hausvetter

    Das mit den Truhen ist wirklich praktisch. :)
     
  14. theSoXX

    theSoXX Ehrbarer Bürger

    Stimmt - wobei sich mir die Frage stellt, ob sich dieser Script auch auf Leichen und Taschen ausweitet.
     
  15. Shor

    Shor Vertrauter

    suppi, jetz warte ich nur noch darauf, dass man endlich tagebücher und notizen selbst beschriften kann :D
     
  16. Treyco

    Treyco Neuankömmling

    also der SKSE funktioniert nicht wirklich sobald ich im game drinne bin dauert es ungefähr 10 Sekunden und Skyrim stürzt ohne Fehelermeldung ab.

    edit: ok ich idiot hab den ordner src vergessen in den Spieleordner zu packen, jetzt funktioniert aber alles einwandfrei!
     
    Zuletzt bearbeitet: 27. November 2011
  17. PlanB

    PlanB Ehrbarer Bürger

    Da ist doch nur der Source Code drin. Seit wann wird der denn benötigt? :huh:
     
  18. theSoXX

    theSoXX Ehrbarer Bürger

    Die Frage, die ich mir eher stelle ist, wie man den SKSE in Verbindung mit dem neuen 4gb-"patch" nutzen soll? :ugly:
     
  19. Wenn das Team den 4GB-Patch als wichtig genug ansieht, finden die eine Lösung.
    Die machen das, was sie da machen, lange genug und wissen, was sie tun. Daher mache ich mir da ehrlich gesagt keine Sorgen.

    Als Problem sehe ich eher Steam. Da kann man nur hoffen, dass die Jungs eng mit Bethesda und Valve zusammenarbeiten. Sonst können wir unter Umständen nach jedem Update Tage oder Wochen auf eine neue SKSE-Version warten, weil die alte plötzlich nicht mehr funktioniert.
     
  20. PlanB

    PlanB Ehrbarer Bürger

    Seit Version 1.2 unterstützt der 4GB Patch auch SKSE.

    Das Spiel muss einfach nur über die skyrim4gb.exe gestartet werden. SKSE wird dann automatisch mitgeladen, falls installiert.
     
    theSoXX gefällt das.
  21. Eldarie

    Eldarie Hausvetter

  22. Werbung (Nur für Gäste)
Die Seite wird geladen...

Diese Seite empfehlen